Degraded Performance on AI Features

Incident Report for Trustero

Resolved

The incident with OpenAI has been resolved.
Posted Jun 11, 2026 - 17:36 PDT

Monitoring

We are monitoring the OpenAI incident.
Posted Jun 11, 2026 - 16:08 PDT

Investigating

We are experiencing degraded performance on AI-dependent features due to an ongoing OpenAI incident.
Posted Jun 11, 2026 - 16:07 PDT
This incident affected: prod.api.infra.trustero.com and app.trustero.com.