Partial Outage

Incident Report for Trustero

Resolved

This incident has been resolved.
Posted Jun 12, 2026 - 13:23 PDT

Monitoring

The system has recovered and we are monitoring.
Posted Jun 12, 2026 - 13:06 PDT

Investigating

We are experiencing a partial outage and are currently investigating.
Posted Jun 12, 2026 - 13:00 PDT
This incident affected: prod.api.infra.trustero.com and app.trustero.com.